Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-16577

Failure to deploy XWiki on WildFly 10.x+ because of CDI scanning

    Details

    • Difficulty:
      Unknown
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      So the story is:

      • This issue was discovered and fixed in XWIKI-13678 by adding a jboss-all.xml file in the XWiki WAR
      • For some reasons I got a problem in Wildfly 14.0.1 with this jboss-all.xml file, see XWIKI-15566. This led me to remove the file and I found it to be working without it. Note: I think I was mistaken and something was cached, leading me to believe it was working.
      • After retesting XWiki on WildFly 14.x and 17.x, I found that it fails unless I put back this jboss-all.xml file to prevent CDI scanning.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                vmassol Vincent Massol
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 hours
                  2h