A disable property has been added as part of
XWIKI-12654 which actually duplicates the inactive property.
The only difference between those is that inactive exists to check if an email has been checked in case of the email verification is activated, where disable property can be used to manually enable/disable users.
It would make much more sense to have only one property to check if a user is active/inactive and another property to check if an email has been checked.
Discussion available on the following thread: https://markmail.org/message/xv2f7qpbybaael6m