Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-17194

XWIKI Office Importer options not available after server started

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 12.2, 11.10.4
    • Fix Version/s: 12.3, 11.10.5
    • Component/s: Office
    • Environment:
      Ubuntu 18.04.4 LTS, Tomcat/9.0.16 , Postgres 11
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      [Edit]
      Reproduction steps:

      • Start XWiki and start an office server
      • Check that you can import office page
      • Switch it to german
      • Check that you can import office page

      Expected result:

      • You can still import office documents after switching language

      Obtained result:

      • The UI to import office page is not available anymore

      [Original description]

      I moved our xwiki installation to a brand new server. i also updated to 12.2 in the process. everything works fine so far - besides the "office importer application". I read the release nodes and migrated the openoffice.serverPorts setting in the xwiki.properties to the new syntax.

      the relevant config looks like this:

      openoffice.autoStart=true
      openoffice.homePath=/usr/lib/libreoffice
      openoffice.serverType=0
      openoffice.serverPorts=8100,8101
      openoffice.maxTasksPerProcess=50
      openoffice.taskExecutionTimeout=30000

      It looks like the office server is started correctly as "verbunden" which means connected is displayed and i'm able to stop/start the server.

      Whats odd is that under "serverport" there aren't the correct ports displayed.

      it should read 8100,8101 as defined in the config.

      On some restarts the serverport value displayed:

      8100.0,8101.0 on others it just reads 8.8 as displayed in the screenshot

      The document importing isn't working  - the menu items are missing. in ckeditor the button to import office documents is greyed out.

      my /var/log/tomcat9/catalina-{date}.out looks clean (attached).

      I also tried to enable trace logging for "org.jodconverter.office". after enabling it i restarted the openoffice server with the admin gui - but no events whatsoever were logged in catalina out.

      Just for testing i also tried it with only one office instance running on port 8100 using the old and new syntax - but the import still wasn't available.

      The extension seems to be installed:

      XWIKI is installed on Ubuntu 18.04.4 LTS with latest patches. I run two xwiki-servers connected to the same database - although currently only the first node is published in dns.

      Am I missing anything or is this a bug? - I tried to read through all available documentation. Any ideas on how to troubleshoot this further?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                surli Simon Urli
                Reporter:
                swinkler Stefan Winkler
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: