Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18797

Filtering by "---" in Owner column doesn't display any result in WikiManager Live Data table

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 13.5-rc-1
    • Fix Version/s: None
    • Component/s: Live Data
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, Firefox 89, using a local instance of XWiki 13.5 RC1 (MariaDB 10.5/ Tomcat 9.0.48)
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Login as Admin
      2. Create some subwikis
      3. (Optional) Grant Wiki Creation right to an user and create also one or more subwikis with the user
      4. Go to Drawer > Wiki Index
      5. In Owner column, filter by an username
      6. Click on filter box, then click on "---"

      EXPECTED RESULTS

      All entries from this Live Data table are displayed back.

      ACTUAL RESULTS

      When selecting "—" from filter box, no entries are displayed.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              iandriuta Ilie Andriuta
              Reporter:
              iandriuta Ilie Andriuta
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: