Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18879

Debian packages pull in Java 17 on Debian bullseye

    XMLWordPrintable

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      I've just installed XWiki from Debian packages on bullseye but found that Tomcat didn't start because of the pulled-in Java 17 JRE (openjdk-17-jre-headless). In order to fix this, I had to manually install the default-jre package to get openjdk-11-jre.

      Please fix package dependencies to default-jre instead of "java8-runtime".

        Attachments

          Activity

            People

            Assignee:
            tmortagne Thomas Mortagne
            Reporter:
            Heini3270 Dirk Heinrichs
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response: