Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-5184

Problem with links to Headers after export to HTML

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.3.1, 2.4 M1
    • Component/s: {Unused} Export
    • Labels:
      None
    • keywords:
      HTML Export URL Link Header
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      When exporting an Xwiki Enterprise site to HTML links referencing headers within page text do not render correctly. Table of contents autogenerated at the top of each page has links based on the headers that DO work correctly when clicked. However for links within the text of the page if a link is inserted referencing a header,it works fine in the wiki, but when exported to HTML the URL is mangled.

      For example: A link within a page should be:
      "xwiki.Main.<PageName>.html#H<Header Name>"

      Is instead rendered as:
      "xwiki.Main.<PageName>#H<Header Name>.html"

      This results in a link that does not function correctly in the exported HTML file.

        Attachments

          Activity

            People

            Assignee:
            mflorea Marius Dumitru Florea
            Reporter:
            robz Rob Zimmer
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response: