Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-5897

Office Viewer Macro fails for ppt files on pages with dashes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 3.0 M2, 2.7.1
    • Labels:
      None
    • Environment:
      XWiki Enterprise 2.7, Apache Tomcat 7.0.2, PostgresSQL 9.0.2-1 (for Win x64), Java 1.6 Update 22, LibreOffice 3.3 RC1, Windows 7 x64 Enterprise, 8 GB RAM, 2 Dual-Core Opteron Processor 2222 (3.0 GHz)
    • Tests:
      Unit
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      I noticed that upon using the Office Viewer Macro on pages with a dash in the name (such as "M-16") with ppt attachments no images are displayed. Renaming the page to something without dashes (such as "M 16") it works flawlessly, again. I figure the problem is that the image URLs include %2D instead of the dash in the filename part. In aboves example this would look something like this: "/bin/temp/Space/M%2D16/officepreview/Space.attachment.ppt/attachment-slide1.jpg"

      Interestingly enough, it works on pages with non-ANSI chars (such as Ä, Ö, Ü, ä, ö, ü).

        Attachments

          Activity

            People

            • Assignee:
              mflorea Marius Dumitru Florea
              Reporter:
              jstoldt Johannes Stoldt
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: