Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-6872

Unable to access a page with "/" in its name

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: Old Core
    • Labels:
      None
    • Environment:
      debian6 64-bit, OpenJDK 1.6.0_18, tomcat 6.0.28, postgresql 8.4, xwiki enterprise 3.1 war
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      I have recently upgraded from XWiki Enterprise 3.0 (HSQLDB all-in-one bundle) to XWiki Enterprise 3.1 (war bundle + tomcat + Postgresql DB). Moved content from the old wiki via XAR backup-restore, no errors encountered in the process. However, a single page has become inaccessible afterwards: links to it are shown everywhere in the GUI normally, but any click on such links (view, copy, delete, rename, rights) yields an empty broswer window and nothing in catalina.out.

      The only sensible difference between that page and all the other ones is its name: it contains "/". An attempt to create another page with a slash in its name gives the same blank window (however, XAR import did produce such a page!)

      A related issue is the inability to delete the incorrectly named page from a production server, will appreciate any workaround.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                areyoukiddingme Areyou Kiddingme
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: