Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-9604

XWiki Packager plugin shouldn't require defining the <smartgwt.version> property

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Right now if you create a contrib project (for ex) and try to write some functional tests using the packager plugin, you'll get the following error if you don't define the smartgwt.version property:

      [ERROR] Failed to execute goal org.xwiki.platform:xwiki-platform-tool-packager-plugin:5.3-SNAPSHOT:package (default) on project application-github-statistics-test-tests: Execution default of goal org.xwiki.platform:xwiki-platform-tool-packager-plugin:5.3-SNAPSHOT:package failed: For artifact {com.smartgwt:smartgwt:null:jar}: The version cannot be empty. -> [Help 1]
      

        Attachments

          Activity

            People

            • Assignee:
              vmassol Vincent Massol
              Reporter:
              vmassol Vincent Massol
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: