XWiki Platform
  1. XWiki Platform
  2. XWIKI-9712

Space Templates should also create the space preferences page

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.3-milestone-2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Issue Links

        Activity

        Marius Dumitru Florea added a comment - - edited

        The current space templates are actually templates for the space home page so currently a space template can only create one page, and that is the space home page. See XWIKI-7358 which introduced this feature.

        Elena-Oana Tabaranu added a comment -

        While the template of the homepage can be indeed selected from the list, the "space creation" or "space template" (similar from the user point of view to the page template) feature does not create the preferences which makes the difference between a basic page to a proper space.

        Eduard Moraru added a comment -

        Closed as a duplicate of XWIKI-12775 since the template hierarchy feature is more powerful and should cover the current use case as well.


          People

          • Assignee:
            Eduard Moraru
            Reporter:
            Elena-Oana Tabaranu
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: