Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-11985

DocumentTree's 'openTo' parameters not working in conjunction with 'root' parameter

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.0
    • Fix Version/s: 6.4.4, 7.0.1, 7.1-milestone-1
    • Component/s: Index
    • Labels:
      None
    • Development Priority:
      High
    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      I've tried:

      {{documentTree showTranslations="false" showAttachments="false" showChildDocuments="true" openTo="document:$doc.documentReference" root="document:Main.WebHome" /}}
      

      and

      {{documentTree root="document:Main.WebHome" showTranslations="false" showAttachments="false" openTo="document:$openToDoc" /}}
      

      Select from the Panel, 'Sandbox.TestPage2' page.

      When using root, the nodes are not get expanded anymore and the item is not highlighted, see bug.png vs. expected.png

        Attachments

        1. firstLevel.png
          firstLevel.png
          44 kB
        2. expected.png
          expected.png
          58 kB
        3. bug.png
          bug.png
          37 kB

          Activity

            People

            Assignee:
            mflorea Marius Dumitru Florea
            Reporter:
            evalica Ecaterina Moraru (Valica)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response: