Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15215

XWiki 10.3 fails to start on MySQL with utf8mb4 encoding

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 9.11.4, 10.3
    • Fix Version/s: 11.3-rc-1
    • Component/s: Event Stream
    • Environment:
      Windows 10 Pro 64 bit, IE11, using a local instance of XWiki 10.2 on MySQL 8.0.11

      MySQL with utf8mb4 encoding
    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      When configured with MySQL Community Server 8.0.11 DB, XWiki 10.3 does not start and the browser gets HTTP ERROR 500.
      Was used JDBC connector 'mysql-connector-java-8.0.11.jar' from https://dev.mysql.com/get/Downloads/Connector-J/mysql-connector-java-8.0.11.zip.

      Also, the server was installed using the Legacy Authentication Method (Retain MySQL 5.x Compatibility).

      Please find attached the log containing the stacktrace.

      The issue was also reproduced by Manuel.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              iandriuta Ilie Andriuta
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: